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Obsah Analýza paket̊u Packet Sniffing Wireshark Cain & Abel Závěr

Obsah prezentace

Co nového se nauč́ıme?

� Odpov́ıme na otázky: Co je analýza paket̊u? Kdy můžeme
analýzu paket̊u použ́ıt? Jak analýzu paket̊u provádět?

� Než můžeme zač́ıt něco analyzovat a dělat závěry, muśıme
nejďŕıve nějaký tok dat zachytit - prozkoumáme tedy metody
zachyceńı toku dat v śıt’i (p̌res rozbočovač, p̌reṕınač (SPAN,
RSPAN)).

� U SPAN a RSPAN si ukážeme konfigurace.

� Řekneme si o nástroj́ıch prosťrednictv́ım kterých lze śıt’ový
traffic zachytit a interpretovat.

� Podrobně o paket snifferu Wireshark.



Obsah Analýza paket̊u Packet Sniffing Wireshark Cain & Abel Závěr

Obsah prezentace

Co nového se nauč́ıme?

� Vysvětĺıme si základńı principy nejběžněǰśıch śıt’ových útok̊u,
navrhneme vhodné zabezpečeńı a za použit́ı nástroje
Cain & Abel demostrujeme útok ARP Spoofing.

V pr̊uběhu cvičeńı budeme vše prakticky testovat na reálném
śıt’ovém zǎŕızeńı a běžných p̌ŕıkladech z praxe.
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Analýza paket̊u

� Mezi použ́ıvané anglické ekvivalenty paťŕı Packet (Protocol)
Analysis nebo Packet Sniffing.

� Představuje zachyceńı a interpretaci śıt’ového provozu.

� Odpov́ıdá na otázky co se děje na śıti.

� Př. Kdo je na śıti, co dělá, jaké použ́ıvá zdroje, kdo s kým
komunikuje, co zatěžuje naš́ı śıt’, identifikuje slabá ḿısta śıtě,
pomáhá odhalit útočńıky a jejich zlomyslné aktivity, . . .

� V reálném śıt’ovém provozu slouž́ı analýza paket̊u p̌redevš́ım
k odhaleńı nestadartně se chováj́ıćıch aplikaćı (p̌r. konflikt
DHCP serveru) nebo ově̌reńı konfigurace aktivńıch śıt’ových
prvk̊u. Odhaleńı útočńıka může být jeden z výsledk̊u.

� Abychom mohli tento typ analýzy provést muśıme použ́ıt
některý z nástroj̊u kategorie Packet Sniffer (Wireshark,
TCPdump, . . . ).
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Packet Sniffer

Před výběrem vhodného nástroje je nutné se zamyslet nad několika
fakty. Co chceme s nástrojem analyzovat (podporované protokoly)?
Jaké jsou naše znalosti? Cena nástroje? Podpora OS? . . .

Obecná charakteristika

� Nástroj umožňuje zachytit
”
surový“ raw śıt’ový provoz

a následně ho interpretovat - vid́ıme komunikaci na úrovni
paket̊u.

� Existuj́ı komerčńı i volně dostupné nástroje.

� Různě uživatelsky p̌ŕıjemná prosťred́ı (GUI - Wireshark,
p̌ŕıkazová řádka - TCPdump).

� Nástroje pracuj́ı pod OS Windows nebo Linux (nebo oboj́ı -
Wireshark).

� Běžné protokoly jako ARP, DNS, DHCP jsou v nástroji
podporovány vždy u netradičńıch protokol̊u to tak být nemuśı.
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Co k odposloucháváńı poťrebujeme?

� Stanici na které budeme zachytávat śıt’ový provoz.

� Námi zvolený packet sniffer nástroj - Wireshark.

� Může se hodit p̌ŕımý Ethernet kabel a hub (viz. dále).

� NIC (Network Interface Card) s podporou promiskuitńıho
režimu (promiscuous mode).

Chováńı NIC s vypnutým promiskuitńım režimem

Śıt’ový provoz, který neńı určen pro stanici, je na základě L2
informaćı v hlavičce rámce zahozen (ARP broadcast). Otázka: Na
které vrstvě OSI modelu je zastaven update protokolu RIPv1 na
PCs v LAN pokud neńı nastaven passive-interface na routeru?

Chováńı NIC se zapnutým promiskuitńım režimem

Igonoruje info v L2 hlavičce a zachyt́ı tak veškerý śıt’ový provoz.



Obsah Analýza paket̊u Packet Sniffing Wireshark Cain & Abel Závěr

Metody odposloucháváńı

Rozd́ıly dle prosťred́ı

� Již jsme zopakovali chováńı rozbočovače a p̌reṕınače. Známe
tedy jejich vniťrńı pracovńı logiku. Toho využijeme p̌ri
naslouchouńı na śıti.

� Koncov́ı uživatelé propojeni p̌res rozbočovač nebo p̌reṕınač.

� Uvědomujete si již nyńı zásadńı rozd́ıl p̌ri nasloucháńı na
zǎŕızeńı hub a switch?

� Jak by jste řešili odposloucháváńı na switchi (viz.dále)?

Ikony použ́ıvané v diagramech
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Použit́ı rozbočovače k odposloucháváńı

� Chová se jako klasický repeater - opakovač.

� Nejideálněǰśı prosťred́ı pro odposloucháváńı (moc neuvid́ıte).

� Je-li našim ćılem koncov́ı host, stač́ı p̌ripojit stanici do
volného portu na daném rozbočovači a zapnout packet sniffer.

� Packet Sniffer p̌redstavuje stanici na které zachycujeme
odposlechnutý provoz (admin). Obět’ - ćıl odposloucháváńı.
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Použit́ı p̌reṕınače k odposloucháváńı

� Uživatelé jsou p̌ripojeny do śıtě p̌res switch.

� Zopakujeme-li p̌ŕıklad zobrazený ńıže pak útočńık uvid́ı pouze
sv̊uj śıt’ový provoz a broadcast (Kdy to neplat́ı?).

� Chceme-li zjistit, co vyśılá
”
obět“ na portu Fa0/15 je poťreba

použ́ıt jiná
”
kouzla“ než jen vše propojit a odposlouchávat.

� Co je MAC Address Flooding? Princip a zabezpečeńı?
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Odposloucháváńı za pomoci rozbočovače v prosťred́ı
p̌reṕınač̊u

� Ideálńı v p̌ŕıpadě, kdy switch nepodporuje zcadleńı port̊u.

� Koncového uživatele, původně p̌ripojeného do portu Fa0/15,
propoj́ıme p̌res rozbočovač s PC na kterém běž́ı paket
analyzátor.

� Samožrejmě muśıme ḿıt fyzický p̌ŕıstup k zǎŕızeńım.

� Pozor na nastavenou L2 port securitu.
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Kontrola konfigurace p̌red zahájeńım činnosti

Výpis konfigurace portu Fa0/1 na Cisco Catalyst 2960

Výpis stavu zabezpečeńı na portu Fa0/1na Cisco Catalyst 2960
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Zrcadleńı portu - Port Mirroring

Základńı charakteristika

� Jinak také Switched Port Analyzer (SPAN).

� Slouž́ı ke koṕırováńı śıt’ového provozu z VLAN, portu nebo
port̊u na vybraný port.

� Umožňuje vidět co p̌richaźı/odcháźı/oboj́ı na port.

� Nutný p̌ŕıstup do p̌ŕıkazové řádky zǎŕızeńı - konfigurace.

� Ově̌rit podporu zrcadleńı na zǎŕızeńı u výrobce.

� Pozor na situaci, kdy chcete zrcadlit port s velkým množstv́ım
trafficu (trunk port). Port, kde je p̌ripojený packet sniffer
nemuśı st́ıhat

”
odbavovat“ všechny pakety a bude je

zahazovat.

� Př. Zdroj trunk port 10Gbps skrz který jde 100 VLANs a ćıl
10Mbps port.

� Velmi důležité a použ́ıvané p̌ri troubleshootingu.



Obsah Analýza paket̊u Packet Sniffing Wireshark Cain & Abel Závěr

SPAN

Základńı charakteristika

� Podḿınka: zdroj (koho chceme odposlouchávat) a ćıl (kam
chceme traffic zrcadlit) muśı být v rámci stejného zǎŕızeńı.

� Na p̌reṕınači poťrebujeme vždy jeden volný port pro p̌ripojeńı
laptopu s analyzátorem.

� Zdroj, který chceme odposlouchávat je p̌ripojen do portu
Fa0/2 a ćıl, kam chceme zrcadlit traffic je na portu Fa0/1.
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SPAN - konfigurace na Cisco Catalyst 2960

Konfigurace SPAN

� Vytvǒŕıme jednu monitorovaćı session pro zdroj i ćıl.

Bližš́ı specifikace zdroje zrcadleńı v onfiguraci SPAN

Výpis aktuálńı konfigurace SPAN
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Remote SPAN

Základńı charakteristika

� Má stejné vlastnosti jako SPAN + rozš́ı̌reńı.

� Rozd́ıl: zdroj a ćıl nejsou na stejném zǎŕızeńı.

� Zdroj (koho monitorujeme) p̌redstavuj́ı hosté na SW2
v VLAN10 a ćıl (packet sniffer) je na SW1 port Fa0/2 VLAN1.
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Remote SPAN - konfigurace na Cisco Catalyst 2960

remote-span VLAN

� Vyžaduje vytvǒrit remote-span VLAN, která bude sloužit pro
p̌renos monitorovaného provozu.

� Remote-span VLAN muśı být na všech p̌reṕınač́ıch, p̌res které
budeme pośılat ze zdroje do ćıle monitorovaćı traffic.

� Remote-span konfigurujeme na všech p̌reṕınač́ıch ručně nebo
na VTP serveru (pokud VTP použ́ıváme).

Vytvǒreńı remote-span VLAN na SW1 a SW2
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Remote SPAN - konfigurace na Cisco Catalyst 2960

� Při RSPAN vytvá̌ŕıme DVĚ monitorovaćı session.

Zdrojová session na SW2

� Na SW2 urč́ıme, že chceme monitorovat celou VLAN10
a vytvǒŕıme zdrojovou session s č́ıslem 2. Ćıl p̌redstavuje
VLAN 100 (remote-span). Pozor, u Cisco Catalyst 2950 je
nutné za druhý p̌ŕıkaz p̌ridat kĺıčové slovo reflector-port

Ćılová session na SW1

� Ćılová session 3 si jako zdroj bere obsah remote span VLAN
100 a pośılá ho na port FA0/2, kde je zapojený packet sniffer.
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Remote SPAN - ově̌reńı konfigurace

#show monitor session
”
č́ıslo“
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Ově̌reńı RSPAN pomoćı nástroje Wireshark

Provoz VLAN10 zachycený na portu Fa0/2 p̌reṕınače SW1

Topologie śıtě
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O programu Wireshark

Základńı charakteristika

� 1. ḿısto v Top Network Security Tools (http://sectools.org/),

� open-source nástroj k analýze a monitorováńı provozu śıtě,

� nástupce nástroje Ethereal, podpora stovek protokol̊u,

� možný zásah do kódu, použit́ı pro osobńı i komerčńı účely,

� Wireshark najdete na každém Forensic Live CD,

� d́ıky GUI velmi snadný a intuitivńı na ovládáńı,

� ideálńı pokud zač́ınáme s monitorováńım a analýzou provozu,

� podporován pod OS Windows i Linux, minimálńı HW nároky,

� nástroj lze stáhnout na (http://www.wireshark.org/),

� triviálńı instalace na OS Windows (WinPcap je součást́ı
instalačky)/OS Linux dle distribuce,

� TcpDump(http://www.tcpdump.org/) sniffer v p̌ŕıkazové řádce.

http://sectools.org/
http://www.wireshark.org/
http://www.tcpdump.org/
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Poprvńı spuštěńı nástroje Wireshark

Uv́ıtaćı plocha, která nijak nev́ıtá :-) Zač́ınáme. . .
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Základńı nastaveńı

Cesta k nastaveńı

Vyberte v hlavńım menu Capture → Options..

� Vyberte rozhrańı na
kterém chcete
monitorovat provoz,

� promiskuitńı mód aktivńı,

� Start.

� Dále si ukážeme, kde lze
změnit defaultńı nastaveńı
pokud nám nevyhovuje
(nap̌r. režim nebo
rozhrańı).



Obsah Analýza paket̊u Packet Sniffing Wireshark Cain & Abel Závěr

Hlavńı pracovńı okno - popis a význam panel̊u v programu

Zachytáváńı ukoč́ıme pomoćı 4. ikony z leva v panelu nástroj̊u
nebo Capture → Stop.
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Pracujeme se zachyceným śıt’ovým provozem

Primitivńı vyhledáváńı

� Stač́ı chv́ıle a zachyt́ıte tiśıce i desetitiśıce paket̊u (r̊uzné
prokoly, IP, MAC adresy, velikosti, flagy, . . . ).

� Klávesové zkratky :Ctrl + F, Ctrl + N, Ctrl + B.

� Do Filtru napǐste nap̌r. název protokolu (icmp).

Netradičně tradičńı Uložit jako - uložte si zachycené pakety

� Vyberte v hlavńım menu File → Save As..
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Nastaveńı filtru p̌red spuštěńım zachytáváńı

Zachytávaćı filtry -
”
Capture Filters“

� Definujeme, co chceme či nechceme aby náš sniffer zachytil.

� K filtrováńı docháźı již p̌ri zachytáváńı śıt’ového provozu.

� Filtry vytvá̌ŕıme pomoćı výraz̊u.

� V hlavńım panelu :Capture → Options..

� Pokud p̌red spuštěńım zachytáváńı v́ıme, že nechceme vidět
protokol ARP, stač́ı do

”
Capture Filters“ napsat řetězec

”
!arp“.
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Filtrujeme pakety až po zachyceńı

Zobrazovaćı filtry -
”
Display Filters“

� Aplikujeme na celou množinu již zachycených paket̊u -
vyfiltrujeme co poťrebuje (nap̌r. traffic na tcp.dstport==23) -
pro návrat do celého dumpu stač́ı smazat filtr.

� Filtry ṕı̌seme ručně do pole pod panel nástroj̊u nebo
použijeme

”
klikátko“ Expression.. Zobrazovaćı filtry jsou

v praxi v́ıce použ́ıvany. Doporučuji psát filtry ručně.
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Operátory ve filtrech

Porovnávaćı operátory

� Porovnávaćı operátory nám umožňuj́ı porovnávat hodnoty
mezi sebou.

� Nap̌r. vyber všechny pakety které maj́ı zdrojovou adresu
172.16.0.3 (ip.src==172.16.0.3).

Logické operátory

� D́ıky logickým operátor̊um můžeme vzájemně kombinovat
několik filtr̊u.

� Nap̌r. vyber všechny pakety které maj́ı zdrojovou adresu
172.16.0.3 a ćılový port 23 (ip.src==172.16.0.3 and
tcp.dstport==23).
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Porovnávaćı a logické operátory

Porovnávaćı a logické operátory
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Vytvá̌ŕıme vlastńı filtry

Několik základńıch p̌ŕıkladů zobrazovaćıch filtr̊u

Skvělý zdroj zobrazovaćıch filtr̊u pro Wireshark
http://media.packetlife.net/media/library/13/Wireshark_Display_Filters.pdf

Cvičeńı

Stáhněte si z Moodlu p̌ripravený dump pro Wireshark, na kterém si
vyzkouš́ıme několik filtr̊u.

http://media.packetlife.net/media/library/13/Wireshark_Display_Filters.pdf
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Někdy pohled na packety nestač́ı

� Umožňuje nám vidět zachycené packety, jak je vid́ı uživatel
obsluhuj́ıćı aplikaci.

� Klikněte pravým tlač́ıtkem myši na packet v hlavńım panelu
→ Follow TCP Stream.
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Spojte packety do streamu

� Výborný nástroj pro analýzu p̌renášeného obsahu.

� Vyzkoušejte zachyceńı komunikace: z libovolného IM klienta,
ze vzdálené správy směrovače p̌res protokol Telnet, z p̌renosu
souboru protokolem TFTP.
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Extra nastaveńı

Změna vlastnost́ı defaultńıho profilu

� Vyberte v hlavńım menu Edit → Preferences...

� V sekci
”
Capture“ lze vybrat rozhrańı a zvolit promiskuitńı

režim jako defaultńı (platné od p̌ŕı̌st́ıho spuštěńı nástroje).
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Extra nastaveńı

Změna formátu času

� Vyberte v hlavńım menu View → Time Display Format →..

� Neznám defualtńı nastaveńı, ale pro řešeńı r̊uzných problemů
je nutné nastaveńı měnit(někdy stač́ı minuty jindy milisec).

� Čas i datum se bere ze systému - pozor na správné nastaveńı.

Změna barevných profil̊u

� Vyberte v hlavńım menu View → Coloring Rules..
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Odposloucháváńı jako typ śıt’ového útoku

Nástroj Caine & Abel si p̌redstáv́ıme hned několikrát v tomto
kurzu. Na tomto ḿıstě ho použijeme k demostraci śıt’ového útoku
ARP spoofing. Co nás bude a nebude zaj́ımat?

� Nejde nám o to v kurzu trénovat typy útok̊u!!!

� Tento typ útoku bude jediný, který si v laboratorńıch
podḿınkách vyzkouš́ıme.

� Uvid́ıte, zda teoretický princip skutečně chápete a zdali jste
schopni tento typ triviálńıho útoku odhalit.

� Dále v této prezentaci si zopakujeme základńı principy
některých śıt’ových útok̊u, které nám stač́ı k tomu, abychom
věděli, jak zabezpečit śıt’ a dále kde hledat bezpečnostńı
mezery (nap̌r. p̌ri forenzńı analýze).
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ARP Poisoning/ARP Spoofing

Základńı charakteristika

� Nikoli běžná metoda odposloucháváńı provozu ale útok na
p̌reṕınač, typ Man in The Middle,

� výsledkem útoku je, že umožńı odposlouchávat śıt’ový provoz
(nap̌r. konkrétńıho hosta), jako ďŕıve zḿıněné metody,

� k pochopeńı tohoto typu útoku je kĺıčové znát p̌resně, jak
funguje protokol ARP (Address Resolution Protocol).

� Co v́ıte o ARP spoofingu? Jak prob́ıhá podrvžeńı MAC adresy?

� Jaké existuje zabezpečeńı proti tomuto typu útoku?

Otev̌rete si ve Wiresharku dump, který máte p̌ripravený v moodlu.
Identifikujte chováńı běžného ARP dotazu a ARP spoofingu.
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Caine & Abel

� 6. p̌ŕıčka v Top Security Tools, GUI nástroj pod OS Windows,

� dle oficiálńıch stránek
”
Password Recovery Tool“, freeware,

� obsahuje obrovské monožstv́ı integrovaných funkćı jako nap̌r.
śıt’ový sniffer, cracker (slovńıkový a brute-force útok), ARP
spoofing, hash dump, . . .

� oficiálńı stránky nástroje: http://www.oxid.it//.

http://www.oxid.it//
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Topologie p̌ŕıkladu pro ARP Spoofing

� Nastavte adresu rozhrańı
směrovače a IP adresu
VLAN1 na p̌reṕınači.

� Na p̌reṕınači nastavte
možnost vzdáleného
p̌ŕıstupu protokolem
Telnet.

� Ćıl: útočńık bude
zachytávat provoz mezi

”
Obět́ı“ p̌ristupuj́ıćı na

p̌reṕınač pomoćı
protokolu Telnet
a p̌reṕınačem.

� Funkčnost ově̌rte
programem Wireshark.
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Caine & Abel

Vykonáńım samotného útoku se nebudeme p̌ŕılǐs zabývat
a použijeme p̌ripravené video (moodle).

� Protokolem ICMP ově̌rte konektivitu mezi hosty.

� Před začátkem simulace útoku spuste na všech PC Wireshark.

� Ve Wiresharku sledujte, jak se projev́ı sken śıtě (identifikace
zǎŕızeńı na śıti).

� Pozorujte ve Wiresharku, jak
”
Útočńık“ podvrhne MAC.

Zkontrolujte obsah ARP tabulek.

� Připojte se vzdáleně z
”
Oběti“ na p̌reṕınač p̌res protokol

Telnet a vypǐste běž́ıćı konfiguraci.

� Na PC, kde sed́ı
”
Útočńık“ ve Wiresharku zobrazte obsah

p̌renášený protokolem Telnet (mezi obět́ı a p̌reṕınačem).

� Aplikujte Vámi navržené zabezpečeńı p̌red t́ımto typem útoku
a celý postup opakujte.
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Nejběžněǰśı śıt’ové útoky

Chcete-li, co nejlépe zabezpečit Vaš́ı poč́ıtačovou śıt’ p̌red útoky, je
důležité chápat základńı teoretické principy, jak takové útoky
prob́ıhaj́ı. D́ıky tomu jste schopni určit, jakých bezpečnostńıch
mezer ve Vaš́ı konfiguraci může útočńık využ́ıt.

Běžné śıt’ové útoky

� ARP Spoofing/ARP Poisoning (Již známe).

� MAC Address Table Overflow/MAC Address Flooding.

� VLAN Hopping.

� Útoky na Spanning-tree.

Odpovězte na ńıže uvedné otázky

� Popǐste základńı princip útoku.

� Navrhněte vhodné zabezpečeńı.
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Děkuji za pozornost!
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